Hi,
I’m standing up a new delegate and re-learning a whole bunch of things
Anyways, I was reading docs about SceneIndexPlugins and I found this piece of a plugInfo.json
in the docs:
{
"Plugins": [
{
"Info": {
"Types": {
"MyFilterPlugin" : {
"bases": ["HdSceneIndexPlugin"],
"loadWithRenderer": "GL",
"priority": 0,
"displayName": "My awesome filter scene index"
}
}
},
"LibraryPath": "@PLUG_INFO_LIBRARY_PATH@",
"Name": "myfilter",
"ResourcePath": "@PLUG_INFO_RESOURCE_PATH@",
"Root": "@PLUG_INFO_ROOT@",
"Type": "library"
}
]
}
I was wondering: what should the loadwithRenderer
field be set to?
Is this simply the exact displayName
of my renderer?
Or is there a non-cosmetic setting I should use?
At the moment my displayName
is something like "OTR (1.2.3)"
, I was thinking that maybe some kind of internal name could be more robust? Say something like hdOTR_1_2_3
or whatever.
I would love some guidance, if possible.
Many thanks
Luca
PS: Great to see you all again, it’s been a while