USDView does not render anything

I installed USDView via the Omniverse Launcher. I tried to open different USD files, but none of them is being rendered in the Viewport. I cannot see any error messages. In the viewport only the bounding boxes of the prims are being shown.

I’m using a pretty old Nvidia Geforce MX150 GPU. Can this be the reason? However, in Blender the Hydra PBR rendering works.

Thank you for any help in advance!

Hmm… Storm’s GL requirements are pretty modest, but I suppose if it’s a really old GPU that could be the issue.
What OS are you using, and precisely how are you launching usdview?

Hi Paul,
thanks for your reply. I’m using Windows 11 23H2, and I’m launching it through the Omniverse launcher.

Do I need to install OpenUSD? GitHub - PixarAnimationStudios/OpenUSD: Universal Scene Description

When I run usdview.cmd I get this error: “line 28, in
import pxr.Usdviewq as Usdviewq
ModuleNotFoundError: No module named ‘pxr’”

Open a shell, and instead of running bin/usdview.cmd, try scripts/usdview.bat, and see if there’s any error output.

It’s possible that launching via Omniverse is causing the error system to get sent to a non-existent terminal and swallowed.

…and just for your info - the error when running bin/usdview.cmd is expected - USD requires certain env vars to be setup, which is what the scripts/usdview.bat does.

Also - to avoid having to pass a path to a USD file, you can use scripts/usdview_gui.bat

Hi Paul,
I tried both, scripts/usdview.bat and scripts/usdview_gui.bat. USDView opens and there is no error. But I cannot see the meshes.

Anyway, I assume my GPU is just tool old.