UsdView Black Screen

Hey
I was trying to build USD from scratch on windows 10 with building the dependencies before with python 3.11.
While i got the main API build and e.g. python bindings are working i have an issue with the USDView.

I tried disabeling all optional dependencies like OCIO/OIIO/MTLX but this didn’t solve the issue.

EDIT: i tried building with the buildscript.py and got the same issue.
It seems like the UsdView opens twice. First time it opens, it immediatly closes and then opens again.

Does anyone has an idea/suggestion what e.g. library or part of the building process could cause that kind of an issue?

Thanks for the help in advance.

Cheers
Jonas

Hi @jonassorgenfrei. Welcome to the forums!

I wonder if maybe its using your integrated GPU instead of your dedicated GPU. To check and if that’s the case, you’d need to make sure that your dedicated GPU is set to be used for the usdview python process. (e.g. via NVIDIA Control Panel) More info here: ASWF Slack Thread

Hey @mati-nvidia

thanks for your fast answer.

Hmm i actually don’t have an integrated GPU just a dedicated GPU (2080ti). So i couldn’t find that setting in the nvidia control panel.
I try to see if a system restart helps as i had some other 3d applications open might have inteferred.

I gave it a quick with the usdview shipping with houdini and that one works.

Nvidia Pre Builds work too, but both are using Python 3.10 and i tried 3.11.

I build USD with Python 3.10 and it shows up again!
So i assume it’s some Python 3.11 issue/incompatibility.

Logged as bug: Windows Py3.11 issues with OpenGL in USDView · Issue #2996 · PixarAnimationStudios/OpenUSD · GitHub