23.08 Build Script Edit

Hey all,

Bit of a weird question but I believe around July when I first tried building USD for v23.08 I ran into some issues. I remember searching through the issues on the Github and coming across a certain issue where someone had replied and mentioned that changing two lines of code in one of the scripts fixed their issue, and it did so for me as well. Unfortunately I can’t remember which script exactly (it was definitely a python script), nor which post, but if someone is able to find it or knows what I am talking about and could link it to me, that would be amazing. I remember the file being long (I would like to think the fix was around line 600 but I could be entirely wrong).

are you hitting issues now, or do you remember the issues you were hitting? There aren’t inherent patches that are needed unless there is a specific edge case not handled, so I think it would be hard to provide an answer without more information

Sorry it took so long to get back to you. Back when I posted it not particularly, but now I have an issue where the build will complete successfully, my virtual environment is activated, and I have my system paths set up properly, but my pxr folder is essentially empty: I can import pxr but none of the classes (Usd, UsdGeom, etc) are built.

I would suggest treating it like a brand new problem since there doesn’t seem to be a strong thread otherwise.

I think the information that would help folks help you would be things like:

  1. What USD version are you trying to build?
  2. What OS and compiler are you using?
  3. Can you upload a build log somewhere in case there’s an error that’s not being caught?

Hey, sorry that’s my bad, forgot to include all of that:

  1. We are trying to buiild 23.08 (I have it built but we wanted to try another system because I had a lot of struggles with it and then it magically worked randomly)
  2. Windows 11 Visual Studio Community 2017
  3. Here is the log file for the sucessful build (3.2 MB)


We tried building without python docs and it just worked? There is a strange error when running USDView however. OpenColorIO prints the message "color management disabled (set the $OCIO environment variable) which is not something I have come across throughout my various builds of USD.

I used the --opencolorio flag when building.

I suppose this just means that - yes, there’s OCIO support in your build but you have not configured an OCIO config for your running process (which is usually done via the OCIO environment variable.)

Also see OpenColorIO Environment Variables.

Could that be the case?

Hi @BigRoyNL yes, we never set the environment variable, but in my previous installs of USD I never had to do this manually, it always worked out of the box. I will try this and add the results here but do you potentially know why it would require me to add it manually now?